aboutsummaryrefslogtreecommitdiffstats
path: root/www-apps/cgit/cgit-1.2.3-r3.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-05-26 15:46:45 +0200
committerWynn Wolf Arbor2020-05-26 15:46:45 +0200
commit2bba0e5eb6e39b29d2c819bf329bb72179f1518a (patch)
tree189d786d2300dca8f66183fdeefacf9c7a4c71ce /www-apps/cgit/cgit-1.2.3-r3.ebuild
parent375aee3c489dccd8fed2a26cd0aa25a45b3b01a3 (diff)
downloadpramantha-2bba0e5eb6e39b29d2c819bf329bb72179f1518a.tar.gz
www-apps/cgit: Bump to 1.2.3-r3
Add support for a static build. Since e6b07da278, git does not use OpenSSL's SHA1 implementation anymore and instead uses its own DC_SHA1. The only other part of git that depends on ssl is git-imap-send (which is not used by cgit), so drop the ssl dependency from cgit. Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to '')
-rw-r--r--www-apps/cgit/cgit-1.2.3-r3.ebuild (renamed from www-apps/cgit/cgit-1.2.3-r2.ebuild)27
1 files changed, 18 insertions, 9 deletions
diff --git a/www-apps/cgit/cgit-1.2.3-r2.ebuild b/www-apps/cgit/cgit-1.2.3-r3.ebuild
index a801587..2b57dcb 100644
--- a/www-apps/cgit/cgit-1.2.3-r2.ebuild
+++ b/www-apps/cgit/cgit-1.2.3-r3.ebuild
@@ -15,9 +15,9 @@ SRC_URI="https://www.kernel.org/pub/software/scm/git/git-${GIT_V}.tar.xz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="doc highlight libressl lua luajit lzip markdown zip zstd"
+IUSE="doc highlight lua luajit lzip markdown static zip zstd"
-LUADEP="
+LUA_DEPEND="
lua? (
luajit? ( dev-lang/luajit )
!luajit? ( dev-lang/lua:0 )
@@ -29,19 +29,25 @@ BDEPEND="
>=app-text/asciidoc-8.5.1 )
"
-RDEPEND="${LUADEP}
+RDEPEND="${LUA_DEPEND}
dev-vcs/git
highlight? ( || ( dev-python/pygments app-text/highlight ) )
lzip? ( app-arch/lzip )
markdown? ( dev-python/markdown )
zip? ( app-arch/zip )
zstd? ( app-arch/zstd )
+ !static? ( sys-libs/zlib )
"
-DEPEND="${LUADEP}
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- sys-libs/zlib
+DEPEND="${LUA_DEPEND}
+ static? (
+ sys-libs/zlib[static-libs(+)]
+ )
+"
+
+# +static fails with +luajit
+REQUIRED_USE="
+ static? ( !luajit )
"
src_prepare() {
@@ -54,6 +60,8 @@ src_prepare() {
echo "libdir = ${EPREFIX}/usr/$(get_libdir)" >> cgit.conf
echo "CACHE_ROOT = ${CGIT_CACHEDIR}" >> cgit.conf
echo "DESTDIR = ${D}" >> cgit.conf
+ echo "CGIT_SCRIPT_PATH = ${EPREFIX}/usr/libexec/cgit" >> cgit.conf
+ echo "CGIT_DATA_PATH = ${EPREFIX}/usr/share/cgit/resources" >> cgit.conf
if use lua; then
if use luajit; then
echo "LUA_PKGCONFIG = luajit" >> cgit.conf
@@ -71,6 +79,7 @@ src_configure() {
)
export MY_MAKEOPTS="${myopts[@]}"
+ LDFLAGS="${LDFLAGS} $(usex static -static '')"
}
src_compile() {
@@ -86,6 +95,6 @@ src_install() {
}
pkg_postinst() {
- ewarn "For caching support, /var/cache/cgit needs to exist and be owned"
- ewarn "by the user executing cgit."
+ ewarn "For caching support in its default configuration, /var/cache/cgit"
+ ewarn "needs to exist and be owned by the user executing cgit."
}