aboutsummaryrefslogtreecommitdiffstats
path: root/sys-power/upp/upp-0.1.7.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2023-09-23 18:58:00 +0200
committerWolfgang Müller2023-09-23 18:58:00 +0200
commit1db9df7b1d1ced4bacb9ad1e43ff60830c2101b1 (patch)
treec3b73b1aac3d572d1dfb3b638bb7f4e1b82aa4e1 /sys-power/upp/upp-0.1.7.ebuild
parentb73cf7dc4497e57e8531a560df3ac3ec28356250 (diff)
downloadpramantha-1db9df7b1d1ced4bacb9ad1e43ff60830c2101b1.tar.gz
sys-power/upp: new package, add 0.1.7
Diffstat (limited to '')
-rw-r--r--sys-power/upp/upp-0.1.7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-power/upp/upp-0.1.7.ebuild b/sys-power/upp/upp-0.1.7.ebuild
new file mode 100644
index 0000000..f697ec6
--- /dev/null
+++ b/sys-power/upp/upp-0.1.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11,12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="A tool for parsing, dumping and modifying data in Radeon PowerPlay tables"
+HOMEPAGE="https://github.com/sibradzic/upp https://pypi.org/project/upp/"
+
+KEYWORDS="amd64 x86"
+
+RESTRICT="test"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/click[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"