aboutsummaryrefslogtreecommitdiffstats
path: root/sys-fs/zfs_autobackup/zfs_autobackup-3.1.3.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2022-07-21 19:30:35 +0200
committerWolfgang Müller2022-07-21 19:30:35 +0200
commit6b0c3016c097f84aaf959fdf5dbfd55d41c9f496 (patch)
treea39419c2111b3524bcccfd2afe69b031c98c4ca7 /sys-fs/zfs_autobackup/zfs_autobackup-3.1.3.ebuild
parent3fdc9bb933059a30951bb7fcb8a80ab6c174cce0 (diff)
downloadpramantha-6b0c3016c097f84aaf959fdf5dbfd55d41c9f496.tar.gz
sys-fs/zfs_autobackup: add 3.1.3, drop 3.1.2
Diffstat (limited to 'sys-fs/zfs_autobackup/zfs_autobackup-3.1.3.ebuild')
-rw-r--r--sys-fs/zfs_autobackup/zfs_autobackup-3.1.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-fs/zfs_autobackup/zfs_autobackup-3.1.3.ebuild b/sys-fs/zfs_autobackup/zfs_autobackup-3.1.3.ebuild
new file mode 100644
index 0000000..4a895c4
--- /dev/null
+++ b/sys-fs/zfs_autobackup/zfs_autobackup-3.1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10} )
+inherit distutils-r1
+
+DESCRIPTION="Periodicly backup ZFS filesystems"
+HOMEPAGE="https://github.com/psy0rz/zfs_autobackup https://pypi.org/project/zfs-autobackup/"
+
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="amd64 x86"
+
+RESTRICT="test"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/colorama[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"