aboutsummaryrefslogtreecommitdiffstats
path: root/net-irc/quasselgrep/quasselgrep-0_p20190211-r1.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-05-15 15:07:01 +0200
committerWynn Wolf Arbor2020-05-15 15:07:01 +0200
commit8fe51997602efd83ae5e90dcdd41f50f9a3c56c6 (patch)
treea8c469a649d2612f436413d46058c89a8cc3e228 /net-irc/quasselgrep/quasselgrep-0_p20190211-r1.ebuild
parent5bcb113e0c970cc9c33c36b40ad40fecef80fe36 (diff)
downloadpramantha-8fe51997602efd83ae5e90dcdd41f50f9a3c56c6.tar.gz
net-irc/quasselgrep: Add 0_p20190211-r1
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to '')
-rw-r--r--net-irc/quasselgrep/quasselgrep-0_p20190211-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-irc/quasselgrep/quasselgrep-0_p20190211-r1.ebuild b/net-irc/quasselgrep/quasselgrep-0_p20190211-r1.ebuild
new file mode 100644
index 0000000..47dc2b7
--- /dev/null
+++ b/net-irc/quasselgrep/quasselgrep-0_p20190211-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="sqlite?"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Tool for searching quassel logs from the commandline"
+HOMEPAGE="https://github.com/fish-face/quasselgrep"
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/fish-face/quasselgrep.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ MY_COMMIT=9b6b0bc1252daa6e574363d87d04eebd981215a5
+ SRC_URI="https://github.com/fish-face/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
+ S="${WORKDIR}/fish-face-${PN}-${MY_COMMIT:0:7}"
+ KEYWORDS="amd64 x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="sqlite +postgres"
+
+RDEPEND="dev-python/future[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )"