aboutsummaryrefslogtreecommitdiffstats
path: root/net-irc/quarg/quarg-0.1.3.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2021-10-21 11:47:35 +0200
committerWolfgang Müller2021-10-21 11:47:35 +0200
commit112e14ce1576c08d9c1e0d187ecb47aa3202505d (patch)
tree3d07d337841fccc4e3670ed4f9fa5ea4fa7ea8ce /net-irc/quarg/quarg-0.1.3.ebuild
parent9bd0326036a08d7388039798d11ab45dce8b530f (diff)
downloadpramantha-112e14ce1576c08d9c1e0d187ecb47aa3202505d.tar.gz
net-irc/quarg: Bump to 0.1.3
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Diffstat (limited to 'net-irc/quarg/quarg-0.1.3.ebuild')
-rw-r--r--net-irc/quarg/quarg-0.1.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-irc/quarg/quarg-0.1.3.ebuild b/net-irc/quarg/quarg-0.1.3.ebuild
new file mode 100644
index 0000000..efb5865
--- /dev/null
+++ b/net-irc/quarg/quarg-0.1.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Search Quassel logs for matching messages and print them"
+HOMEPAGE="https://git.oriole.systems/quarg"
+
+SRC_URI="https://git.oriole.systems/quarg/snapshot/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT="mirror test"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="sqlite postgres"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
+ >=dev-python/sqlalchemy-1.4[${PYTHON_USEDEP},sqlite?]
+"
+
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ default
+
+ doman quarg.1
+}