aboutsummaryrefslogtreecommitdiffstats
path: root/app-shells/fzf/fzf-0.21.1-r1.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-04-26 14:48:09 +0200
committerWynn Wolf Arbor2020-04-26 14:48:09 +0200
commit0c378a92d08608d3e63bf205eafc9de54e01de04 (patch)
tree427ba6c24a0ea053216b01008a2ccdc7abbc1fc8 /app-shells/fzf/fzf-0.21.1-r1.ebuild
parent428fddad58b7f06e89c212b69712074a55f2925d (diff)
downloadpramantha-0c378a92d08608d3e63bf205eafc9de54e01de04.tar.gz
app-shells/fzf: Bump to 0.21.1-r1
Upstream has fixed their Makefile in [1], so we can pull that patch in temporarily and switch over to using make instead of a custom call to go build. This commit also cleans up the ebuild a bit. [1] https://github.com/junegunn/fzf/commit/08c2bcb952a0abbead263dcb002 Package-Manager: Portage-2.3.89, Repoman-2.3.20
Diffstat (limited to '')
-rw-r--r--app-shells/fzf/fzf-0.21.1-r1.ebuild (renamed from app-shells/fzf/fzf-0.21.1.ebuild)54
1 files changed, 30 insertions, 24 deletions
diff --git a/app-shells/fzf/fzf-0.21.1.ebuild b/app-shells/fzf/fzf-0.21.1-r1.ebuild
index 3e7a58d..e618be8 100644
--- a/app-shells/fzf/fzf-0.21.1.ebuild
+++ b/app-shells/fzf/fzf-0.21.1-r1.ebuild
@@ -2,8 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit bash-completion-r1 go-module
+DESCRIPTION="A general-purpose command-line fuzzy finder"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
EGO_SUM=(
"github.com/DATA-DOG/go-sqlmock v1.3.3/go.mod"
"github.com/gdamore/encoding v1.0.0"
@@ -53,47 +57,49 @@ EGO_SUM=(
go-module_set_globals
-KEYWORDS="amd64"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz ${EGO_SUM_SRC_URI}"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ ${EGO_SUM_SRC_URI}"
-DESCRIPTION="A general-purpose command-line fuzzy finder"
-HOMEPAGE="https://github.com/junegunn/fzf"
-
-LICENSE="MIT"
+LICENSE="MIT BSD-with-disclosure"
SLOT="0"
-IUSE="tmux"
-RESTRICT="mirror"
+KEYWORDS="amd64 x86"
RDEPEND="tmux? ( app-misc/tmux )"
-DOCS=( CHANGELOG.md README.md )
+IUSE="tmux"
+RESTRICT="mirror"
-src_compile() {
- go build || die
-}
+DOCS=( CHANGELOG.md README{,-VIM}.md )
+
+PATCHES=(
+ "${FILESDIR}/${P}-0001-Quote-LDFLAGS-1995.patch"
+)
src_install() {
- dobin fzf
- einstalldocs
+ default
- doman man/man1/fzf.1
+ dobin bin/${PN}
- newbashcomp shell/completion.bash fzf
+ doman man/man1/${PN}.1
insinto /usr/share/nvim/runtime/plugin
- doins plugin/fzf.vim
+ doins plugin/${PN}.vim
insinto /usr/share/vim/vimfiles/plugin
- doins plugin/fzf.vim
- dodoc README-VIM.md
+ doins plugin/${PN}.vim
insinto /usr/share/zsh/site-functions
- newins shell/completion.zsh _fzf
- insinto /usr/share/zsh/site-contrib/
- newins shell/key-bindings.zsh fzf.zsh
+ newins shell/completion.zsh _${PN}
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/${PN}/
+ newins shell/key-bindings.bash ${PN}.bash
+ newins shell/key-bindings.fish ${PN}.fish
+ newins shell/key-bindings.zsh ${PN}.zsh
if use tmux; then
- dobin bin/fzf-tmux
- doman man/man1/fzf-tmux.1
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
fi
}