aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava_investor/fava_investor-0.2.1.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2021-01-12 18:09:20 +0100
committerWynn Wolf Arbor2021-01-12 18:09:20 +0100
commit8486d8cc498064117287b2502722708982eb2dea (patch)
treecaa95e510e229ee5d1c7cf651762f9bde758cb92 /app-office/fava_investor/fava_investor-0.2.1.ebuild
parent137bec6fba761fb27362987bd09a27432b9ebabe (diff)
downloadpramantha-8486d8cc498064117287b2502722708982eb2dea.tar.gz
app-office/fava_investor: Add 0.2.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2
Diffstat (limited to '')
-rw-r--r--app-office/fava_investor/fava_investor-0.2.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-office/fava_investor/fava_investor-0.2.1.ebuild b/app-office/fava_investor/fava_investor-0.2.1.ebuild
new file mode 100644
index 0000000..f2e49f9
--- /dev/null
+++ b/app-office/fava_investor/fava_investor-0.2.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fava extension and beancount libraries for investing"
+HOMEPAGE="https://pypi.org/project/fava-investor/ https://github.com/redstreet/fava_investor"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=app-office/beancount-2.3.2[${PYTHON_USEDEP}]
+ >=app-office/fava-1.15[${PYTHON_USEDEP}]
+ >=dev-python/argh-0.23.3[${PYTHON_USEDEP}]
+ >=dev-python/argcomplete-1.11.1[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.3[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"