aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/fava/fava-1.22.3.ebuild
diff options
context:
space:
mode:
authorWolfgang Müller2022-09-01 19:11:04 +0200
committerWolfgang Müller2022-09-01 19:11:04 +0200
commitb10fef97e10f301e24b65b6fd4d5fafc14569ed2 (patch)
tree85edf16613d6ff6e34b83c15c65370e6e79f8624 /app-office/fava/fava-1.22.3.ebuild
parent1f4271431b78f207e2ac959a70cc5783e7667f89 (diff)
downloadpramantha-b10fef97e10f301e24b65b6fd4d5fafc14569ed2.tar.gz
app-office/fava: destabilize 1.22.3 for ~amd64, ~x86
Diffstat (limited to '')
-rw-r--r--app-office/fava/fava-1.22.3.ebuild33
1 files changed, 17 insertions, 16 deletions
diff --git a/app-office/fava/fava-1.22.3.ebuild b/app-office/fava/fava-1.22.3.ebuild
index 59b50cc..dbe50e1 100644
--- a/app-office/fava/fava-1.22.3.ebuild
+++ b/app-office/fava/fava-1.22.3.ebuild
@@ -3,8 +3,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{9,10} )
-
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1
@@ -14,23 +14,24 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
RDEPEND="
- >=app-office/beancount-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/Babel-2.7.0[${PYTHON_USEDEP}]
- >=dev-python/cheroot-8.5.2[${PYTHON_USEDEP}]
- >=dev-python/flask-babel-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/flask-2.0.1[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.0.1[${PYTHON_USEDEP}]
- >=dev-python/click-8.0.1[${PYTHON_USEDEP}]
- >=dev-python/markdown2-2.3.0[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- >=dev-python/simplejson-3.16.0[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-1.0.0[${PYTHON_USEDEP}]
- dev-python/chardet[${PYTHON_USEDEP}]
+ >=app-office/beancount-2.3.0[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/Babel-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/cheroot-8.5.2[${PYTHON_USEDEP}]
+ >=dev-python/flask-babel-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown2-2.3.0[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-1.0.0[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ ')
"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
# test_static_url presumes and requires the existence of these two files.