aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/beancount/beancount-9999.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2021-01-16 13:35:58 +0100
committerWynn Wolf Arbor2021-01-16 13:35:58 +0100
commitaa4fa184aa76c267b5106a4cdd52324915b3bb84 (patch)
tree1f341e51ecdfededa329ab5662df09d35108137e /app-office/beancount/beancount-9999.ebuild
parenta85bdff92db5e38e0b112fae4bd9ca1c92dce38c (diff)
downloadpramantha-aa4fa184aa76c267b5106a4cdd52324915b3bb84.tar.gz
app-office/beancount: Clean up dependencies, use python_gen_cond_dep
Package-Manager: Portage-3.0.12, Repoman-3.0.2
Diffstat (limited to '')
-rw-r--r--app-office/beancount/beancount-9999.ebuild29
1 files changed, 15 insertions, 14 deletions
diff --git a/app-office/beancount/beancount-9999.ebuild b/app-office/beancount/beancount-9999.ebuild
index 0a31ff2..18a460d 100644
--- a/app-office/beancount/beancount-9999.ebuild
+++ b/app-office/beancount/beancount-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -27,19 +27,20 @@ IUSE="emacs"
SITEFILE="50{PN}-mode-gentoo.el"
RDEPEND="
- >=dev-python/python-dateutil-2.6.0[${PYTHON_USEDEP}]
- >=dev-python/bottle-0.12[${PYTHON_USEDEP}]
- >=dev-python/ply-3.4[${PYTHON_USEDEP}]
- >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
- >=dev-python/google-api-python-client-1.8.2[${PYTHON_USEDEP}]
- >=dev-python/oauth2client-4.0[${PYTHON_USEDEP}]
- >=dev-python/httplib2-0.10[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- >=dev-python/python-magic-0.4.12[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- "
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep '
+ >=dev-python/beautifulsoup-4[${PYTHON_USEDEP}]
+ >=dev-python/bottle-0.12[${PYTHON_USEDEP}]
+ >=dev-python/google-api-python-client-1.8.2[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.10[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-4.0[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/python-magic-0.4.12[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
+"
python_compile_all() {
use emacs && elisp-compile editors/emacs/beancount.el