aboutsummaryrefslogtreecommitdiffstats
path: root/app-office/beancount/beancount-2.3.3.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-10-27 13:18:26 +0100
committerWynn Wolf Arbor2020-10-27 13:18:26 +0100
commitbb53b46a7f22cf7d6d3ee1d911444eecfcd8b503 (patch)
treea5ae18ac2e31520e4a44533e08c5026ec5f6efdd /app-office/beancount/beancount-2.3.3.ebuild
parentef5b97072c1e748ad26356594c3e08c385e8f264 (diff)
downloadpramantha-bb53b46a7f22cf7d6d3ee1d911444eecfcd8b503.tar.gz
app-office/beancount: Bump to 2.3.3
Package-Manager: Portage-3.0.8, Repoman-3.0.2
Diffstat (limited to '')
-rw-r--r--app-office/beancount/beancount-2.3.3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-office/beancount/beancount-2.3.3.ebuild b/app-office/beancount/beancount-2.3.3.ebuild
new file mode 100644
index 0000000..272b808
--- /dev/null
+++ b/app-office/beancount/beancount-2.3.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1 elisp-common
+
+DESCRIPTION="Command-line Double-Entry Accounting"
+HOMEPAGE="http://furius.ca/beancount https://pypi.org/project/beancount"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="emacs"
+
+SITEFILE="50{PN}-mode-gentoo.el"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/bottle-0.12[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.0[${PYTHON_USEDEP}]
+ >=dev-python/google-api-python-client-1.8.2[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-4.0[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ >=dev-python/python-magic-0.4.12[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ "
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use emacs && elisp-compile editors/emacs/beancount.el
+}
+
+python_install_all() {
+ rm -rf "${ED}/usr/elisp" || die "removing erroneous elisp files failed"
+
+ distutils-r1_python_install_all
+
+ if use emacs; then
+ elisp-install ${PN} editors/emacs/beancount.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}