aboutsummaryrefslogtreecommitdiffstats
path: root/app-backup/lifeboat/lifeboat-1.0.0_beta.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-02-01 18:08:33 +0100
committerWynn Wolf Arbor2020-02-01 18:08:33 +0100
commit76a7dd2d8a1fa846baf4a1dd8feee49aba3e68c9 (patch)
tree643aba1ba5b16c2756960a359f227d4f52b7c5be /app-backup/lifeboat/lifeboat-1.0.0_beta.ebuild
parent735c5ca9edee663d0b8b7e889a55950e46fb7f7c (diff)
downloadpramantha-76a7dd2d8a1fa846baf4a1dd8feee49aba3e68c9.tar.gz
app-backup/lifeboat: Bump to 1.0.0_beta
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Diffstat (limited to '')
-rw-r--r--app-backup/lifeboat/lifeboat-1.0.0_beta.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-backup/lifeboat/lifeboat-1.0.0_beta.ebuild b/app-backup/lifeboat/lifeboat-1.0.0_beta.ebuild
new file mode 100644
index 0000000..3c1a3d7
--- /dev/null
+++ b/app-backup/lifeboat/lifeboat-1.0.0_beta.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3 user
+
+DESCRIPTION="Manage and automate local restic backups"
+HOMEPAGE="https://oriole.systems"
+EGIT_REPO_URI="https://git.oriole.systems/lifeboat.git"
+EGIT_COMMIT="1.0.0-beta"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-backup/restic"
+BDEPEND=""
+
+pkg_setup() {
+ enewgroup lifeboat
+ enewuser lifeboat -1 /bin/sh /srv/backup/lifeboat lifeboat
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}