aboutsummaryrefslogtreecommitdiffstats
path: root/app-backup/lifeboat/lifeboat-1.0.0_beta-r1.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-02-27 13:12:49 +0100
committerWynn Wolf Arbor2020-02-27 13:12:49 +0100
commitce802df5258eecbbad9dfc05bed40a60e56a8765 (patch)
tree52ca6c9f68d457c8728b76279964253843db4005 /app-backup/lifeboat/lifeboat-1.0.0_beta-r1.ebuild
parentb7d0f3807b47b4cbb3c060089b5d8720f0d2ad23 (diff)
downloadpramantha-ce802df5258eecbbad9dfc05bed40a60e56a8765.tar.gz
app-backup/lifeboat: Bump to 1.0.0_beta-r1
This change will introduce GLEP 81 users for lifeboat. Additionally, as app-backup/restic has been stabilized, we can stabilize this package as well. Package-Manager: Portage-2.3.84, Repoman-2.3.20
Diffstat (limited to '')
-rw-r--r--app-backup/lifeboat/lifeboat-1.0.0_beta-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-backup/lifeboat/lifeboat-1.0.0_beta-r1.ebuild b/app-backup/lifeboat/lifeboat-1.0.0_beta-r1.ebuild
new file mode 100644
index 0000000..34f4b10
--- /dev/null
+++ b/app-backup/lifeboat/lifeboat-1.0.0_beta-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3
+
+DESCRIPTION="Manage and automate local restic backups"
+HOMEPAGE="https://oriole.systems"
+EGIT_REPO_URI="https://git.oriole.systems/lifeboat.git"
+EGIT_COMMIT="1.0.0-beta"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ acct-group/lifeboat
+ acct-user/lifeboat"
+
+RDEPEND="${DEPEND}
+ app-backup/restic"
+BDEPEND=""
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}