aboutsummaryrefslogtreecommitdiffstats
path: root/app-backup/lifeboat/lifeboat-0.1.1-r1.ebuild
diff options
context:
space:
mode:
authorWynn Wolf Arbor2020-01-13 17:23:27 +0100
committerWynn Wolf Arbor2020-01-13 17:23:27 +0100
commit5ecbe27cfe1e7f93b7b3f2a8bced5cee9ab8e477 (patch)
tree47fd6919ebf0d585dc60f94aec3f96287138ddf8 /app-backup/lifeboat/lifeboat-0.1.1-r1.ebuild
parent741952f7a6b83e595bdcb1a9daf01298c8ac52fa (diff)
downloadpramantha-5ecbe27cfe1e7f93b7b3f2a8bced5cee9ab8e477.tar.gz
app-backup/lifeboat: Bump to 0.1.1-r1
This commit will have the lifeboat ebuild create the user and group automatically. Note that we still use enewgroup/enewuser since there seems to be no UID/GID range for custom user overlays with the new acct-* allocation system. Package-Manager: Portage-2.3.79, Repoman-2.3.16
Diffstat (limited to '')
-rw-r--r--app-backup/lifeboat/lifeboat-0.1.1-r1.ebuild (renamed from app-backup/lifeboat/lifeboat-0.1.1.ebuild)9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-backup/lifeboat/lifeboat-0.1.1.ebuild b/app-backup/lifeboat/lifeboat-0.1.1-r1.ebuild
index f36a8db..d09c162 100644
--- a/app-backup/lifeboat/lifeboat-0.1.1.ebuild
+++ b/app-backup/lifeboat/lifeboat-0.1.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3
+inherit git-r3 user
DESCRIPTION="Manage and automate local restic backups"
HOMEPAGE="https://oriole.systems"
@@ -20,6 +20,11 @@ RDEPEND="${DEPEND}
app-backup/restic"
BDEPEND=""
+pkg_setup() {
+ enewgroup lifeboat
+ enewuser lifeboat -1 /bin/sh /srv/backup/lifeboat lifeboat
+}
+
src_compile() { :; }
src_install() {