aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--pyproject.toml45
1 files changed, 45 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..7f5435f
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,45 @@
+[build-system]
+requires = ["poetry-core"]
+build-backend = "poetry.core.masonry.api"
+
+[tool.poetry]
+name = "later"
+version = "0.1.0"
+description = "Manage watch_later entries as saved by mpv(1)"
+authors = [
+ "Juhani Krekelä <juhani@krekelä.fi>",
+ "Wolfgang Müller <wolf@oriole.systems>"
+]
+license = "MIT"
+homepage = "https://git.oriole.systems/later"
+repository = "https://git.oriole.systems/later"
+documentation = "https://git.oriole.systems/later/about"
+
+[tool.poetry.scripts]
+later = 'later.main:main'
+
+[tool.poetry.dependencies]
+python = "^3.8"
+
+[tool.poetry.group.dev.dependencies]
+pytest = "^8.0.0"
+
+[tool.pytest.ini_options]
+pythonpath = ["src"]
+
+[tool.ruff.lint]
+# https://docs.astral.sh/ruff/rules/
+select = [
+ "F", # pyflakes
+ "E", # pycodestyle
+ "W", # pycodestyle
+ "I", # isort
+ "UP", # pyupgrade
+ "A", # flake8-builtins
+ "B", # flake8-bugbear
+ "SIM", # flake8-simplify
+ "FURB" # refurb
+]
+
+[tool.ruff.lint.flake8-builtins]
+builtins-ignorelist = ["exit"]