summaryrefslogtreecommitdiffstatshomepage
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index f4ff147..2a3dec1 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -49,6 +49,7 @@ select = [
"W", # pycodestyle
"I", # isort
"UP", # pyupgrade
+ "A", # flake8-builtin
"B", # flake8-bugbear
"SIM", # flake8-simplify
"FURB" # refurb
@@ -56,6 +57,9 @@ select = [
ignore = ["B007", "SIM102", "SIM108"]
+[tool.ruff.lint.flake8-builtins]
+builtins-ignorelist = ["copyright", "filter", "hash", "id", "input"]
+
[tool.pytest.ini_options]
pythonpath = ["src"]