summaryrefslogtreecommitdiffstatshomepage
path: root/pyproject.toml
diff options
context:
space:
mode:
authorWolfgang Müller2024-11-14 16:11:29 +0100
committerWolfgang Müller2024-11-14 16:28:12 +0100
commit98426ee2034c8f77ac3a1b3fc22ee68f094519b0 (patch)
treef6c10bfc82f354ec6b2a5b93277d787f5b73b2b7 /pyproject.toml
parent2eff6f0bd75c9959b7b899d169164343cd0377c9 (diff)
downloadhircine-98426ee2034c8f77ac3a1b3fc22ee68f094519b0.tar.gz
backend/lint: Add some more useful linters
These should come in handy in the general case, especially bugbear.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml14
1 files changed, 12 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 6b013f1..20e1b75 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -41,8 +41,18 @@ sphinx-issues = "^4.1.0"
requires = ["poetry-core"]
build-backend = "poetry.core.masonry.api"
-[tool.ruff]
-lint.select = ["E", "F", "I", "W"]
+[tool.ruff.lint]
+# https://docs.astral.sh/ruff/rules/
+select = [
+ "F", # pyflakes
+ "E", # pycodestyle
+ "W", # pycodestyle
+ "I", # isort
+ "UP", # pyupgrade
+ "B", # flake8-bugbear
+ "SIM", # flake8-simplify
+ "FURB" # refurb
+]
[tool.pytest.ini_options]
pythonpath = ["src"]