summaryrefslogtreecommitdiffstatshomepage
path: root/pyproject.toml
diff options
context:
space:
mode:
authorWolfgang Müller2024-03-21 14:06:34 +0100
committerWolfgang Müller2024-03-21 14:06:34 +0100
commitc4d4120c44418b10fd9a81e224ab55485cb5cad4 (patch)
tree477af54bc565b6a822de067b57f379bf3b67fe35 /pyproject.toml
parentd1d654ebac2d51e3841675faeb56480e440f622f (diff)
downloadhircine-c4d4120c44418b10fd9a81e224ab55485cb5cad4.tar.gz
build/deps: Update Python dependencies
Update all Python dependencies to their latest compatible versions. Additionally, update strawberry-graphql to 0.220.0 and uvicorn to 0.29.0.
Diffstat (limited to '')
-rw-r--r--pyproject.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 2af84e9..c0df161 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -17,9 +17,9 @@ anchira_yaml = "hircine.plugins.scrapers.anchira:AnchiraYamlScraper"
[tool.poetry.dependencies]
python = "^3.12"
sqlalchemy = {version = "^2.0.0", extras = ["aiosqlite", "asyncio"]}
-strawberry-graphql = "^0.219.1"
+strawberry-graphql = "^0.220.0"
starlette = "^0.37.0"
-uvicorn = {extras = ["standard"], version = "^0.27.0.post1"}
+uvicorn = {extras = ["standard"], version = "^0.29.0"}
pillow = "^10.1.0"
blake3 = "^0.4.1"
alembic = "^1.13.1"