aboutsummaryrefslogtreecommitdiffstats
path: root/conf.c (follow)
Commit message (Collapse)AuthorAgeLines
...
* Start simplifying menu code; and in turn, remove a cursor no longerokan2016-10-03-4/+3
| | | | needed.
* Defaults are split between defines and conf_init(); normalize these, asokan2016-10-03-5/+6
| | | | well as give 'sticky' groups its own variable.
* Use instinsic X11 functions for key/btn/ptr grab/ungrab/regrab requests;okan2016-09-30-7/+27
| | | | | the one line wrappers provided no value and limited altering calls where needed; additionally, most of them had but one caller.
* Mechanical change: move screen menu bits to their own struct.okan2016-09-29-4/+4
|
* Continue merging kb and mouse functions: foldokan2016-09-22-4/+7
| | | | | | mousefunc_menu_{client,cmd,group} into the respective kbfunc_menu_{client,cmd,group} functions; simply pass a flag down from config denoting mouse action behaviour.
* change 'sticky' to 'stick' to toggle client stickiness (seems theokan2016-09-12-3/+3
| | | | | default binding worked for everyone for a long time!); conflict with group sticky found by Ali Farzanrad - thanks!
* add a column to previous commit for consitency.matthieu2016-08-13-2/+2
|
* conf_screen: report the fontname that can't be opened in case of failure.matthieu2016-08-13-2/+2
| | | | ok dcoppa@
* Fix a typo from r1.201; fixes window_grouptoggle binding.okan2015-11-17-2/+2
|
* more client vs screen context differencesokan2015-11-12-23/+23
|
* Move kb pointer movement out of the kbfunc_client_moveresize since it'sokan2015-11-12-49/+49
| | | | | | | | got nothing to do with clients, thus doing flags work causes lots of waste and almost useless jumpy pointer movements; while here, split out move and resize since they share almost no code, just like mouse client move/resize; factor out amount and factor. Still wonder why this is here, but it works now.
* Start cleaning up name vs function differences; replace magic numbers.okan2015-11-10-101/+123
|
* On execwm, we should properly release resources before exec'ing into aokan2015-09-16-2/+2
| | | | | | | new window manager; so allow CWM_EXEC_WM to assign new wm to wm_argv and pass through cwm_status (now EXECWM) so that x_teardown() gets called before exec'ing the new window manager. Removes the need for a separate x_restart() now, using new wm_argv; and consolidates errno for execvp.
* Implement _NET_CLIENT_LIST_STACKING (from Thomas Admin), butokan2015-08-24-1/+2
| | | | bottom-to-top order, as per spec (notified Thomas as well).
* Sort _NET_WM_STATE Atoms like the spec.okan2015-08-24-2/+2
|
* Fix whitespace.okan2015-08-21-27/+27
|
* Add client freeze extension to _NET_WM_STATE Atom, allowing flag tookan2015-08-21-1/+2
| | | | persist. As usual with new Atoms, requires X restart.
* Leave command list order from .cwmrc alone; remove sort.okan2015-08-21-9/+2
|
* Alter big move and resize bindings to match what's in cwm(1);okan2015-08-20-9/+9
| | | | | | | functionally the same, but re-binding should be based on default bindings. Matches other similiar bindings. Discovered by a portable user.
* introduce 'groupsearch' for group menu search; matches on either groupokan2015-07-12-1/+2
| | | | number/shortcut and/or name.
* styleokan2015-07-01-3/+3
|
* keep cmdq sortedokan2015-06-30-2/+10
|
* style and spacing nitsokan2015-06-30-4/+4
|
* merge kbd and mouse grouptoggleokan2015-05-21-3/+3
|
* Make window name and window class separate parameters to conf_autogroup.kspillner2015-05-17-6/+15
| | | | | | No functional change, but will be used shortly. ok okan@
* Simplify key/mb binding moving argtype into flags and dropping anotherokan2015-03-26-13/+9
| | | | | variable; removes the need to zero out struct binding, leaving a simple malloc.
* calloc -> mallocokan2015-01-24-2/+2
|
* use malloc over calloc hereokan2015-01-23-2/+2
|
* Switch to limits.h; replace MAXPATHLEN and MAXHOSTNAMELEN with PATH_MAXokan2015-01-19-2/+3
| | | | | | and HOST_NAME_MAX+1, respectively. ok doug@
* these client actions are just toggles; less confusing with better namesokan2014-09-17-7/+7
|
* Implement EWMH _NET_WM_STATE_HIDDEN.okan2014-09-17-1/+2
|
* more style nitsokan2014-09-07-11/+11
|
* Move termpath and lockpath into cmdq; side effect is that 'lock' andokan2014-09-06-20/+12
| | | | 'term' now show up in the application menu.
* Implement _NET_WM_STATE_STICKY, bound to CM-s by default; allows anyokan2014-08-25-1/+4
| | | | | | | client to 'stick' to all desktops (ewmh speak) or groups - this currently has the same affect as setting a client's group to 'nogroup', with the exception that the client can also be in a group, so when un-sticking, the client will go back to its original group/desktop.
* Continue effort to bring keyboard and mouse functions together; mergeokan2014-08-24-31/+21
| | | | name_to_kbfunc and name_to_mousefunc.
* Purely mechanical; unify 'num', 'no' and 'shortcut'.okan2014-08-20-3/+3
|
* Remove unnecessary memset since reload was replaced with restart;okan2014-08-19-3/+1
| | | | from Kent Spillner.
* plug memleak (currently unused func); from Tiago Cunhaokan2014-04-21-1/+2
|
* No need to store screen colormap and visual; rather just use the Xokan2014-02-02-7/+8
| | | | macros in the one place they are needed.
* The menu already limits entries with MENU_MAXENTRY, so don't botherokan2014-02-02-6/+6
| | | | holding a command name limit as well.
* Switch ignoreq to winname struct since it's basically the same thing;okan2014-01-30-19/+14
| | | | removes limit on name matching.
* use the same autogroupwin variable as everywhere elseokan2014-01-30-7/+7
|
* Remove duplicate mouse functions and instead use the kbfunc ones. Nookan2014-01-30-6/+6
| | | | | user visable changes at this point, but they'll merge at an appropriate time.
* Minimize trivial differences between a few kb and mb functions.okan2014-01-29-2/+2
|
* Merge keybinding and mousebinding queues into using the same mergedokan2014-01-29-24/+23
| | | | | struct, binding; they were essentially the same accept for what was 'pressed', keysym or button.
* Much like we do for keyboard and mouse bindings, remove duplicates forokan2014-01-29-1/+16
| | | | command name - last match.
* Check command name/path for truncation and provide user feedback duringokan2014-01-29-14/+24
| | | | | | config parse (and use conf_cmd_add to populate defaults); based on a discussion with Tiago Cunha. While this looks ugly, there are likely some other changes here to come.
* Check ignore windowname for truncation and provide user feedback duringokan2014-01-28-3/+5
| | | | config parse; based on a discussion with Tiago Cunha.
* no need to quote within warningokan2014-01-23-3/+3
|
* Somewhat streamline event loop/restart/quit handling; most notableokan2014-01-22-3/+3
| | | | | | | | change allows a restart to trigger proper teardown first, even though teardown is not (yet) complete. After some discussion with oga@nicotinebsd.org regarding a more complicated version/idea.