| Commit message (Expand) | Author | Lines |
2016-11-14 | Define callbacks, then default bindings. | okan | -2/+2 |
2016-10-24 | Get rid of 'matchname'; it's too surprising to have the menu change during | okan | -2/+1 |
2016-10-18 | Refactor callbacks to take a void * so as to not try and generalize into | okan | -120/+122 |
2016-10-12 | remove another unused proto | okan | -2/+1 |
2016-10-06 | Rename 2 kbfunc to match closer to what they do | okan | -4/+4 |
2016-10-06 | Add an argument to the callbacks to pass the xevent context, button or | okan | -38/+38 |
2016-10-05 | Stash wmname into conf. | okan | -2/+2 |
2016-10-04 | When removing xrandr regions, ensure clients are within the bounds of | okan | -1/+2 |
2016-10-04 | Calculate client nameqlen in client_setname(), the only place it's | okan | -3/+2 |
2016-10-04 | Turn CALMWM_NGROUPS define into variable, ngroups. | okan | -2/+2 |
2016-10-03 | Start simplifying menu code; and in turn, remove a cursor no longer | okan | -4/+3 |
2016-10-03 | Defaults are split between defines and conf_init(); normalize these, as | okan | -12/+7 |
2016-09-30 | remove unused proto | okan | -2/+1 |
2016-09-30 | Use instinsic X11 functions for key/btn/ptr grab/ungrab/regrab requests; | okan | -8/+1 |
2016-09-30 | Replace mousefunc_sweep_draw() with a generic menu_windraw() using va | okan | -1/+3 |
2016-09-29 | Mechanical change: move screen menu bits to their own struct. | okan | -3/+5 |
2016-09-28 | Inline Xft draw and extents wrappers; too much abstraction. | okan | -4/+1 |
2016-09-22 | Continue merging kb and mouse functions: fold | okan | -5/+1 |
2016-09-20 | de-static client_inbound() | okan | -1/+2 |
2016-09-16 | During init, query screen for _NET_ACTIVE_WINDOW and set that client as | okan | -2/+3 |
2015-11-12 | more client vs screen context differences | okan | -8/+6 |
2015-11-12 | Move kb pointer movement out of the kbfunc_client_moveresize since it's | okan | -12/+11 |
2015-11-11 | Partial revert of replacing screen_area() with region_find(); until a | okan | -2/+7 |
2015-11-10 | Start cleaning up name vs function differences; replace magic numbers. | okan | -25/+24 |
2015-11-09 | Clean up unused defines. | okan | -4/+1 |
2015-11-09 | Extend region to include both view and work areas; switch to | okan | -6/+4 |
2015-09-16 | On execwm, we should properly release resources before exec'ing into a | okan | -2/+4 |
2015-08-27 | Mechanical change: group->gc | okan | -2/+2 |
2015-08-25 | Split out sticky mode checks and the restoring of a client's group and | okan | -2/+4 |
2015-08-24 | Implement _NET_CLIENT_LIST_STACKING (from Thomas Admin), but | okan | -1/+3 |
2015-08-24 | Sort _NET_WM_STATE Atoms like the spec. | okan | -2/+2 |
2015-08-21 | Add Xkb modifier to ignore mask; from Alexander Polakov. | okan | -2/+2 |
2015-08-21 | Fix whitespace. | okan | -7/+7 |
2015-08-21 | Add client freeze extension to _NET_WM_STATE Atom, allowing flag to | okan | -2/+3 |
2015-07-12 | introduce 'groupsearch' for group menu search; matches on either group | okan | -1/+3 |
2015-06-30 | Introduce a callback for cmd menu printing, special-casing 'lock' and | okan | -1/+2 |
2015-06-26 | Mechanical change from xinerama to region backed areas. | okan | -3/+2 |
2015-06-26 | collect 'gap' applications | okan | -1/+2 |
2015-06-26 | Replace screen region info gathering with XRandR equivalent of Xinerama | okan | -2/+1 |
2015-06-09 | typo in comment; from jsteinha [at] iutbayonne.univ-pau.fr | okan | -2/+2 |
2015-06-08 | stash window dimensions | okan | -1/+5 |
2015-06-05 | add a flag to indicate a menu list instead of overloading 'prompt' | okan | -1/+2 |
2015-05-21 | merge kbd and mouse grouptoggle | okan | -3/+1 |
2015-05-20 | fill in mwm defines | okan | -4/+20 |
2015-05-17 | Make window name and window class separate parameters to conf_autogroup. | kspillner | -2/+3 |
2015-03-28 | Introduce a xreallocarray and convert a few xcalloc instances that do | okan | -1/+2 |
2015-03-26 | Simplify key/mb binding moving argtype into flags and dropping another | okan | -2/+2 |
2015-01-19 | Switch to limits.h; replace MAXPATHLEN and MAXHOSTNAMELEN with PATH_MAX | okan | -3/+3 |
2014-10-08 | make group_init work like other *_init's | okan | -3/+3 |
2014-09-27 | these have nothing to do with 'sticky', but rather group membership; rename. | okan | -3/+3 |