aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorbernd2007-04-27 17:58:48 +0000
committerbernd2007-04-27 17:58:48 +0000
commit055eec93ac495df814cc5585fd55712a6cac06c4 (patch)
treea7f9e9b6a1231b28b552199ac2e27c45d64a9ba7 /Makefile.am
downloadcwm-055eec93ac495df814cc5585fd55712a6cac06c4.tar.gz
Initial import of cwm-3.
tested by sturm@, ok matthieu@
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..37205b5
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,19 @@
+include $(top_srcdir)/Makefile.am.inc
+
+CC = gcc
+
+man_MANS = cwm.1
+
+bin_PROGRAMS = cwm
+
+cwm_DEPENDENCIES = @ERRO@ @LIBOBJS@
+cwm_SOURCES = calmwm.c draw.c screen.c xmalloc.c client.c grab.c \
+ search.c util.c xutil.c conf.c input.c xevents.c \
+ group.c geographic.c kbfunc.c cursor.c font.c
+cwm_LDADD = @ERRO@ @LIBOBJS@ $(XFT_LIBS)
+
+AM_CFLAGS = -Wall -Icompat $(XFT_CFLAGS)
+
+EXTRA_DIST = LICENSE README cwm.1 strlcpy.c err.c Makefile.am.inc \
+ compat/sys/queue.h compat/sys/tree.h hash.h calmwm.h \
+ headers.h strlcat.c